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Introduction to Microsoft Project 2010 

This document provides an introduction in using Microsoft Project 2010. Microsoft Project is a 

project management application that contains a set of tools to help managers plan, schedule, 

and control projects.  The project plan file acts as a repository for all project-related information, 

including task lists, resources, calendars, and cost data.  

The Project Environment 

 

The different views of a project allow you to view the specifics of different areas of your project. 

Highlighted below are some views that may be found useful. Access these under the Task tab. 

 

Creating a Project Plan 

There are multiple ways to create a project plan – from a blank project, from a template, from an 

existing project, and from Excel. 

Default View:  Gantt Chart 

Timescale 

Multiple built-in views  
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To create a project, 

1. From the File tab, choose New. 

2. Select the desired method and click Create. 

 

The first required step in creating a project is to enter either a start or a finish date. 

1. From the Project tab, click Project Information. 

 
2. Set the desired Start or Finish Date and click OK. 

 
3. Additional project properties can be identified. 
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a. From the File tab, choose Project Information, then Advanced Properties. 

 
b. Complete the fields, as desired.  Click OK. 

 

Assigning a Project Calendar 

For Project to correctly determine a schedule, working and non-working times should be 

included.  Project has three default base calendars – Standard (traditional), 24 Hours, and Night 

Shift.  Each base calendar can be customized to meet your needs. 

To create a calendar, 

1. From the Project tab, click Change Working Time. 
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2. Click Create New Calendar. 

 
3. Enter a name for the calendar, select a type, and click OK. 

 
4. Specify exceptions (holidays, non-working days/hours). Click OK. 

 
5. Note:  This is not where individual employee time-off is entered. 
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To assign the calendar to the project, 

1. From the Project tab, click Project Information. 

 
2. Select the desired calendar from the dropdown list and click OK. 

 

Creating a Task List and Work Breakdown Structure 

Once you have created a project plan and assigned a calendar, the tasks can be entered.  Tasks 

can also be imported from Excel or Outlook. 

1. Adding Tasks 

First, we will create summary tasks. The summary task is the general focus of a task, and 

contains multiple subtasks below it. The tasks entered below the summary tasks will be 

the specific planned tasks. 

a. To create summary tasks,  

i. Select the View tab, and click Gantt Chart to view the entry mode. 

 
ii. In the Task Name field, type a description of the first major step of your 

project. Continue to enter all the tasks associated with your project. 



[Not for Circulation] 

Information Technology Services, UIS  6 

 

 
b. After creating all your summary tasks, you will begin entering the rest of your 

tasks.  

i. Select the first row under the summary task you are working with, so it is 

highlighted.  

 
ii. Under the Task tab, select Task, and then Task again. You also can add a 

task by right clicking and selecting Insert Task.  

 

iii. Continue to add rows and subtasks until all of your summary tasks are 

detailed and complete. 

2. Organizing Tasks 

Now that all your summary tasks and subtasks are entered, you can organize them into 

a hierarchy to distinguish between them. 

a. Select the Task Name you wish to work with. Under the Task tab, select the 

Indent or Outdent button. 

 
b. After completing your indentations, Project is able to identify summary tasks 

and subtasks based on the indentation pattern. 

 
3. Work Breakdown Structures 

A work breakdown structure is a logical hierarchy of tasks in a project represented by 

alphanumeric codes, similar to an outline. 

You will be able to edit the Duration and Start and 

Finish Dates later on. They now appear because 

Project identifies these tasks as summary tasks  
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a. To view outline numbers on all summary tasks and subtasks, under the Format 

tab, check the Outline Number box. 

 

 
4. Entering Durations 

There are a few specifics to understand when entering durations for tasks in Project. The 

first difference is the differentiation between Duration and Work. Work is the total 

number of hours between all contributors spent on the task, and Duration is the amount 

of time in which you want the task to be completed. It is also important to note that 1 

day is 8 hours and 1 week is 40 hours.  A Unit is the percentage of a resource‟s time 

assigned to a task.   Hence, Work = Duration + Units.  You choose which to enter; Project 

calculates the others. 

a. When we enter durations, we enter them in the subtask cells. The duration of 

the summary task will automatically update according to the subtasks. To enter 

the duration of a subtask, under the Duration column, click inside the empty 

cell. 

 
i. Simply type in the cell the duration you plan to work on the specific task. 

Use units “mo” for months, “w” for weeks, “d” for days, “h” for hours, 

and “m” for minutes.  

ii. A common mistake is to try to fill in all the information all the way across 

(as one would in Excel).  Instead, leave Start and Finish dates empty and 

let Project fill them in.  When manually entered, it deadlocks them as 

constraints which makes Project less useful. 

b. To add work into the spreadsheet to see the amount of total hours the task will 

take, select Add New Column.  

 
i. Scroll down, and select Work.  

ii. The number of hours of total work completed for the task is automatically 

calculated depending on the number of Resource Names and the set 

Tasks are automatically numbered in 

the outline format 

Click the arrows up and down to easily adjust the time 
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Duration. 

 

Resources 

Now that tasks are identified, resources can be assigned to complete them.  Resources are 

categorizes into four types:  Work (people or equipment), Material (paper, ink, toner, etc), Cost 

(airfare, lodging), and Budget (project-level work, material, and cost resources). 

To enter resources, 

1. From the View tab, choose Resource Sheet. 

 
2. Enter the details, as desired. 

 

To assign resources to tasks, 

1. In the Gantt Chart view, under the Resource Names column, select the appropriate 

resource(s) that has been assigned to the task. 

 

Creating Dependencies 

Using dependencies allows Project to be a managing tool rather than just a presentation tool. 

Assigning tasks dependencies demonstrates which tasks are reliant on the completion of others, 

and allows you to change the duration of one task and see the effect on the entire project. 
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1. To link tasks together, select the first task that needs to completed, and then the task that 

can then be started. Use this pattern to link as many tasks as desired by holding the Ctrl 

key.  

 
2. Click the Link Tasks icon under the Task tab.  

 
3. You will now see how each task leads to another on the timeline. 

 
4. After linking tasks and creating dependencies, you will notice numbers automatically 

entering under the Predecessors column. These numbers represent the ID of the task 

(the row number) that must be completed prior to the highlighted task. 

 
5. After you have linked the tasks under a summary task, the days of duration next to the 

summary task will update to be the sum of all the subtasks linked to the specific summary 

task.  

Predecessors and Dependency Types 

Creating relationships among tasks is key to creating realistic schedules.  Relationships occur 

when the starting time of a task is dependent on whether another task is starting or is 

completed.   

Remember to link them in the order in which 

they are dependent upon each other. 

Summary tasks should not be linked. 



[Not for Circulation] 

Information Technology Services, UIS  10 

 

There are four types of dependencies: 

 FS (Finish to Start): The task cannot be started until the predecessor task is completed. 

 SS (Start to Start): The task cannot be started until the predecessor task is started. 

 FF (Finish to Finish): The task cannot be finished until the predecessor task is finished. 

 SF (Start to Finish): The task cannot be finished until the predecessor task begins. 

To enter a predecessor, 

1. In the Predecessors column of the desired task, enter the number of the row the task is 

dependent upon.  

2. Double-click to select the specific dependency type of the task. 

 
3. The link is displayed in the Gantt Chart. 

 

Adding Milestones 

A milestone is a task that acts as a reference point, marking a major event in the project and 

which is used to monitor the project‟s progress. 

To add a milestone, 

1. Click the row below the row of where you want to add your milestone. 

2. Select the Milestone icon under the Task tab. 

 

The link between 

the two tasks 
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3. Type the task name of your milestone. 

 
4. The milestone will then appear on the calendar timeline with an asterisk.  

 
5. Any task can be identified as a milestone by making the duration value 0. 

Deadlines, Constraints, and Notes 

Constraints are conditions or limitations placed on the start or finish date of a task.  Deadlines 

are target dates that indicate when you want a task to be completed. Note are additional or 

supporting information. 

To add a constraint or deadline to a task, 

1. Double-click the task. 

2. In the Task Information dialog box, select the Advanced tab.  Enter the 

constraints/deadlines as desired. 

 

To add a note to a task, 

1. Double-click the task. 

2. In the Task Information dialog box, select the Notes tab.  Enter the desired information. 
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Tracking Progress 

Tracking the progress of a project can be done with baselines. Baselines copy the plan for a 

project before anything is done, and then are compared with the progress throughout the 

project to track tasks and growth.  This is how we determine later if we are „on track‟. 

1. To set a baseline,  

a. Under the Project tab, click Set Baseline.  

 
b. Select if you want the baseline to be for the entire project or selected tasks, and 

click OK. 

 
c. To view the baseline, under the Gantt Chart view, to the right of the screen you 

will see the bars indicating progress on different tasks.  

 
2. To update tasks as you progress through the project,  

The bottom bar is the baseline, and 

the top bar is the actual duration 
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a. Under the Task tab, click to highlight the task you wish to update, and Mark on 

Track in the Schedule box, and then click Update Tasks.   

 
b. You are able to edit the % complete of the task, as well as the duration and dates. 

When finished, click OK. 

 
3. For another way to enter actual Finish dates to track the complete progress of tasks of a 

project,  

a. Under the Task tab, select the View dropdown menu, and choose Task Usage 

Tools. In a New Column, add Actual Finish. 

 
b. To view the progress, under the Task tab, click the View dropdown menu and 

select Tracking Gantt.  

 

Select the date the task is 

actually completed 

View the actual dates and completion of each task 

on the weekly calendar. Top bars represent actual 

duration, and bottom bars are baselines. 

Edit the actual duration of a task as it changes. You 

can also insert actual start and finish dates here. 
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Printing Reports 

While Views can be printed, there are built-in reports that are already pre-defined for easier 

printing.  

1. From the Project tab, in the Reports category, select Reports. 

 
2. Select which type of report you would like to see, and click Select. In the next box, click 

the specific report you would like to print and click Select again. 

 
3. Selecting a report will take you directly to the print preview, where you can view the 

report to be printed on the right, and select Print and edit printing options. 

 
 


