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1. Introduction 

To create a long document like a thesis in Microsoft Word 2007, you need a suitable template 

that contains the appropriate styles and settings. Every paragraph (including headings) in Word 

has a "style" associated with it. A style is a collection of formatting instructions, including font 

family and point size, alignment, amount of space before and after the paragraph, etc. When 

creating a long structured document like a thesis, it is important that you apply styles consist-

ently. 

The Rensselaer thesis template (RPIthesis.dotx), available for download, conforms to the 

requirements of the Graduate School. It includes styles for chapter and section headings (with 

automatic numbering), as well as regulation margins, page number placement, automatic 

formatting of title pages, and Table of Contents compilation. 

2. Downloading the RPI Thesis Template and Prototype Files 

You will need to download several files, all found on the web at: 

 

http://www.rpi.edu/dept/arc/docs/word-thesis/ 

 

1. First, download the Microsoft Word Template file RPIthesis.dotx:   

right-click on the link, select "Save Target as", and save it in the Microsoft Office Tem-

plates folder. In Windows 7 this folder is located at: 

 

 C:\users\your-userid\AppData\Roaming\Microsoft\Templates 

 

If you want to keep your thesis files together, save a copy of RPIthesis.dotx with your other 

thesis related files. 

 

2. Next, copy the Word prototype file that contains the boiler-plate text for the title page as 

well as pages to use for Abstract, tables of contents, etc. There is also an additional one-

page file for the abstract title page, needed only for doctoral dissertations. Place the file(s) 

in the folder you will use for your thesis, such as “Documents\Thesis”. 

The files you want to download are:  

 

For a masters thesis: 
 RPIfrontpages-mas.docx 

RPIabstitlepage-mas.docx 

 

      For a doctoral thesis: 
 RPIfrontpages-phd.docx 

 RPIabstitlepage.docx  

3. About the RPI Thesis Template 

The general layout of the Rensselaer thesis template is as follows: 

 

 Top and bottom margins are 1 inch. 

http://www.rpi.edu/dept/arc/docs/word-thesis/
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 Left margin is 1.55 inches. 

 Right margin is 1 inch. 

 Footer, which contains the page number, is 0.5 inch from edge of the paper. 

 Line spacing is “line and a half” (acceptable to Graduate School). 

 Font of body paragraphs is Times Roman, 12 points. 

 

The RPIthesis template provides the following Microsoft Word paragraph styles: 

(The Frontmatter heading and Headings 1-3 are included in the Table of Contents by default.) 

 

Title   for the Title of the thesis. 

Frontmatter  for “Abstract” and similar headings that are not numbered. 

Heading 1   for chapter headings. Numbered, centered, starts a new page. 

Heading 2   for section headings. Numbered, left-justified. 

Heading 3   for subsection headings. Numbered, left-justified. 

Headings 4-6  for subsubsection headings, etc., if needed . 

Body Text   for paragraphs that are not indented. This is the default style for  

   paragraphs following section headings. 

Body Text First Indent   for indented paragraphs. This is the default for all other   

   body paragraphs.  

Caption: Figure  can be used to reformat an existing figure caption in boldface 

   and in the same size font as the rest of the document. 

Caption: Table  can be used to reformat an existing table caption in boldface  

   and in the same size font as the rest of the document. 

Block Quote   for single-spaced quotations, set off and indented left and right. 

Bibentry   can be used for bibliography items. It uses single spacing, and  

   subsequent lines have a hanging indent. 

4. Applying the Template and Using Styles 

To get started, first open the appropriate frontpages file (either RPIfrontpages-mas.docx or 

RPIfrontpages-phd.docx). Then, to apply the template, follow these steps. 
  

1. Click on the Office buton , then click Word Options. 

2. In the Word Options window, click on Add-ins. Select Templates from the Manage drop-

down menu and click Go. 

3. In the Templates and Add-Ins window, the currently attached template is displayed. Click 

on Attach.  

4. In the Attach Template window, navigate to the folder where you saved the RPIthesis.dotx 

and select RPIthesis.dotx and click Open. 

5. In the Templates and Add-Ins window, select Automatically update document styles, 

remove any other templates, and click OK. 

 

All your front matter (which includes the title page, all the tables of contents, acknowledge-

ment, abstract, etc) is in this file. If your thesis is relatively short, and you want it all in one file, 

you can create the entire thesis by adding to this file (see Section 6). For a long thesis, leave 
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this file for just the front pages, and create each new chapter as a separate file (see Section 7). 

Later, you will start with the front pages file and append all the chapter files, as described in 

Section 14. 

 

As mentioned previously, it’s very important to use the template’s styles as you work, particu-

larly for the headings. First, to make sure Word will display the template styles rather than ad 

hoc formatting choices, click on the Office buton and click on Word Options. In the Word 

Options window, select Advanced. Uncheck the box next to Keep track of formatting. Click 

OK.  

 

Next, click on the Home tab. In the Styles section of the toolbar, click on the arrow pointing 

down and to the right          to display the Styles task pane. Look for these styles in 

the Styles task pane:  Bibentry, Caption: Figure, Caption: Table, Frontmatter, headings, etc.  

You can customize the Styles task pane look and feel by clicking on Options…. 

To apply a style, do the following:  

1. Click the words or paragraph to which you want to apply the style or just click in the spot 

where you’d like to begin typing in a certain style, such as a heading.  

2. Find the style you want in the Styles task pane and click its name.  

Note that when you click in a paragraph, its style is displayed in the Styles task pane. 

5. The RPIfrontpages File 

In the RPIfrontpages prototype file, the first page is the RPI thesis title page. You will need to 

replace the title, author, advisers, etc. with your own information. You can delete the copyright 

page if you don’t want it. For now, leave all the Tables of Contents pages as they are (empty); 

they will get filled in later after you complete the thesis. (See Section 16).  After typing your 

own information, you can save this file with a different name if you wish. 

6.  Putting the Thesis All in One File (short thesis) 

If your thesis is relatively short, you can use your frontpages file for the whole thesis. Start 

your first chapter by moving to the end of the file (use Ctrl-End).  

 

 Click on the Page Layout tab and click on Breaks and select Next Page under Section 

Breaks.  

 Position the cursor on the new page and from the style choices, select Heading 1. Type the 

title of your first chapter, and press Enter. 

 Click on the Insert tab, click on Page Number. Select Bottom of page then select Plain 

Number 2. 

 You are now editing the footer.  
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 Note the Same as Previous label. Click on Link to Previous to start a different footer for 

this section. The Same as Previous label vanishes. 

 In the footer, right click on the page number and select Edit Field…. 

 In the Field window,  

 

 

select Page from Field names list. For Format, select 1, 2, 3 … from the list. 

 Click OK. 

Note: If the page number “1” doesn’t appear on the bottom center of your new page, be sure 

you started a new section with the page break, not simply a new page. To change the number, , 

right click on the page number and select Numbering.  

To add subsequent chapters, just select the “Heading 1” style. The heading will start a new 

page, and the page numbering will continue from the previous chapter. Continue to write the 

thesis by applying the various heading styles as needed for sections and subsections. It is 

essential to use the heading styles provided by this template! Styles for Heading 1 through 
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Heading 6 will format the headings correctly in your chapters and mark the headings (by 

default levels 1-3) for proper inclusion in your Table of Contents. 

See Section 16 for instructions on how to update your tables of contents, cross references, etc. 

7. Creating the Chapters as Separate Files (long thesis) 

If your thesis is long, it is easier to work with smaller files, and should anything happen to 

destroy a file, you lose less of your work. Start a new file for each chapter, using the RPI thesis 

template: first start Word, then click on the Office button and select New. In the New Docu-

ment window, click on My Templates under Templates. In the New window, click on 

RPIthesis.dotx to highlight it, and click OK.  

While working, it is essential to use the heading styles provided by this template! Styles for 

Heading 1 through Heading 6 will format the headings correctly in your chapters and mark the 

headings (by default levels 1-3) for proper inclusion in your Table of Contents. The chapter 

numbering and page numbering will start with “1” in each file, but after you assemble the 

chapters (see Section 14), the numbering will be sequential. 

8. Inserting Figures, Tables and Captions 

Note that captions for tables usually go above the table, while captions for figures go below the 

figure.  

Insert a table into your document by clicking on the Insert tab, then click on Table. Choose the 

number of rows and columns or use one of the other methods to create your table. Enter your 

information.  

To make a caption, click somewhere inside the table. Click on the References tab, then click 

on Insert Caption.  

In the Caption window, 

 

make sure Table is selected for the Label field. The Position field should be Above selected 

item. Click on Numbering.... In the Caption Numbering window,  
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select Include chapter number. Select Heading 1 for the Chapter starts with style field and 

period for the Use separator field. 

The text “Table 1.1” will be inserted above your table. Follow this with the text of your cap-

tion. By default, the caption will be left-aligned and in a smaller font. To put it in the same size 

font as the rest of the document, highlight the entire caption (left-click 3 times) and apply the 

style Caption: Table. To center it (recommended for one-line captions), simply select the 

entire caption and click the center icon on the Home ribbon. 

Insert a figure in your document either by creating a drawing or by inserting an image from a 

file. Make the caption in the same way as for a table. Click on the figure, click on the Refer-

ences tab, then click on Insert Caption. Make the Label field says Figure and the Position 

field says Below selected item. To put it in the same size font as the rest of the document, 

highlight the entire caption (left-click 3 times) and apply the style Caption: Figure. To center 

it (recommended for one-line captions), simply select the entire caption and click the center 

icon on Home  ribbon.  

To refer to a figure or table in your document (for example “see Figure 1.2”), see the instruc-

tions in Section 11,  Cross References.  

9. Equations 

If the Microsoft Word 2007 equation editor does not meet your needs, you might consider 

MathType from Design Science. This program integrates with Word by extending the capabili-

ties of Word’s equation editor and providing an additional MathType menu. See  

http://www.mathtype.com/ . The academic price is $57. However, if your thesis is heavy on 

mathematics, you may want to consider using LaTeX instead of Word to create your thesis. See 

http://helpdesk.rpi.edu/update.do?artcenterkey=325. 

10.  Footnotes 

Create a footnote
 
by clicking on the References tab and selecting Insert Footnote.  Type the 

text of your footnote in the space provided at the bottom of the page. The default gives you 

http://www.mathtype.com/
http://helpdesk.rpi.edu/update.do?artcenterkey=325
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continuously numbered footnotes. To change this behavior, click on the arrow pointing down 

and to the right    to open the Footnote and Endnote window.  

 

 
 

Enter your preferences in the appropriate fields and click Apply. 

 

11.  Cross References 

You can only cross-reference items in the same document. Therefore, before inserting refer-

ences, first assemble your chapters into one document, as described in Section 14.  

In the text of your document, you can insert references to several different types of information, 

such as section headings, figures, and tables. Note that in order to refer to figures and tables, 

you must create the captions using insert caption as described in Section 8. 

 First place the cursor where you want to create the cross reference in your text.  

 Click on the Insert tab, then click on Cross-reference.  

 In the Cross-reference window, select the Reference type from the drop-down menu.  

Select the type of item you want to refer to such as figure, table, or heading. 

 From Insert reference to drop-down menu, select the information you want to insert (for 

example, page number). 
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 In the For which drop-down menu, click the specific item you want to refer to, such as the 

particular caption to which you are referring. 

 Select the settings for Insert as hyperlink, Include above/below, and Separate number with 

fields. 

 Click Insert, then click Close. 

  

12.  Quotations 

A block quotation is a long quotation, too long to go inline. It appears in the document as a 

separate paragraph, indented from both left and right, smaller line spacing, and separated from 

the paragraphs above and below by some vertical space. To make a block quotation, just apply 

the style “Block quote”. 

13.  Back Matter 

To create headings for appendices or a bibliography, use the “Heading 1” style if you want 

these sections to be numbered sequentially with your chapters. If you don’t want them num-

bered, use the “Frontmatter” heading style. 

To format your bibliography entries using hanging indentation, use the “Bibentry” style.  

 

14.  Assembling the Thesis from Separate Files 

If your thesis is in separate files, you will build the entire thesis by opening the file containing 

your front matter and then appending each subsequent file in turn, as follows: 

First, save and close all chapter files. Next, open your frontpages file and use “Save as” to give 

it a name appropriate for your whole thesis. Doing this preserves your original frontpages file 

for backup purposes. 

Add the first chapter to the end of the whole thesis file, as follows: 

1. Go to end of the introductory material (Ctrl-End).  

2. Click on the Page Layout tab, then click on Breaks and select Next Page under Section 

Breaks.  

3. Place cursor at top of newly created page, then: 

4. Click on the Insert tab, then click on the arrow to the right of Object in the Text group 

 

 
 

and select Text from file… from the drop-down menu. 
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5. In the Insert File window, locate and highlight the file you want to insert. Click Insert. 

6. In the footer, right click on the page number and select Edit Field…. 

7. In the Field window, select Page from Field names list. For Format, select 1, 2, 3 … 

from the list. 

8. Click OK. 

 

Add the remaining chapters to the end of the whole thesis file, as follows: 

1. Go to end of contents (Ctrl-End).  

2. Click on the Insert tab, then click on Page Break.  

3. Click on the Insert tab, then click on the arrow to the right of Object in the Text group 

 

 
 

and select Text from file… from the drop-down menu. 

4. In the Insert File window, locate and highlight the file you want to insert. Click Insert. 

15.  Building the Table of Contents, List of Tables and List of Figures 

The Table of Contents (TOC) will automatically get filled in when you update (see below), but 

you will need to initially build the List of Tables (LOT) and List of Figures (LOF) yourself: 

 

To build the List of Tables 

1. Go to the page with the heading List of Tables. 

2. Click underneath the heading. 

3. Click on the References tab, then click on Insert Table of Figures.   

4. In the Table of Figures window,  
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select Table from the Caption label drop-down menu. 

5. Be sure the Formats drop-down menu says From template. 

6. Click OK. 

 

To build the List of Figures 

1. Go to the page with the heading List of Figures. 

2. Click underneath the heading 

3. Click on the References tab, then click on Insert Table of Figures.   

4. Select Figure from the Caption label drop-down menu. 

5. Be sure the Formats drop-down menu says From template. 

6. Click OK. 

16.  Updating the Numbering for Tables of Contents, Figure Captions, 

Table Captions, Equations, Cross References 

Note that when you insert new captions, Word automatically updates the numbering of all the 

other captions. But if you delete or move captions, you need to explicitly update, using one of 

the methods below. 
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To update a single field, you can click in a field (e.g., a table number or a cross reference) and 

then press F9. Likewise, to update a list, such as the List of Figures, click in the list, then press 

F9. To update all fields in a document including Figures, Tables, Cross References, Equations, 

TOC, LOT and LOF, click Select All on the Edit menu, and then press F9.   

You now have a completed thesis! 

17.  Creating the PDF Files for Electronic Submission 

Rensselaer requires that electronically-submitted theses or dissertations be in Adobe Portable 

Document Format (PDF). Your PDF files must have all fonts embedded, be text searchable, 

and must not be encrypted. The resolution should be at least 600 dpi. Both Master’s and Ph.D. 

candidates will need to submit two PDF files. 

 

File 1: A PDF file containing the complete thesis or dissertation. 

 

File 2: A PDF file consisting of the abstract title page and the abstract. Note that the 

abstract title page is not the same as the title page for the thesis or dissertation. 

 

The easiest method for creating the PDF files is to save in PDF format. You must install 2007 

Microsoft Office Add-in: Microsoft Save as PDF or XPS before you can save in PDF format in 

Word 2007.  

 

Go to http://www.microsoft.com/downloads/ and search Microsoft Download Center for 

SaveAsPDFandXPS.exe. Download and install the add-in. 

 

Follow these steps to save in PDF format. 

 

1. Click on the File tab, then click on Save as.  

2. In the Save as window, select PDF (*.pdf) from the Save as type drop-down menu. Click 

Save. 

 

Checking the PDF Files 

You should check your PDF files to make sure that everything has converted properly. To do 

so, open the PDF file in Acrobat Reader or Acrobat and page through to visually make sure it 

looks right. To more formally check your fonts, follow these steps: 

 

1. Select File > Properties….  

2. In the Document Properties window, click on the Fonts tab. Verify that all fonts are either 

Type 1 or TrueType (TT) fonts. 

3. You should see Embedded or Embedded Subset for all fonts (with the possible exception of 

Times New Roman, Arial/Helvetica and Courier). 

4. Click OK to close the Document Properties window. 

5. S 

6. From the Advanced menu, click on Use Local Fonts to turn this option off (thecheck mark 

should disappear). 

7. Select Edit > Preferences…. 

http://www.microsoft.com/downloads/
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8. In the Preferences window, click on Page Display. 

9. Click on Use Local Fonts to turn this option off (the check mark should disappear). Click 

on OK. 

10. Page through your PDF file to visually inspect each page as it would appear on another 

computer without the same fonts as yours. 

 

Another option is to use Adobe Acrobat Pro (not the free Adobe Acrobat Reader) to convert 

your Word 2007 document to PDF. Mobile Computing Program laptops come with Acrobat 

Pro pre-installed. Acrobat Pro is available from the Rensselaer Campus Computer Store at a 

low educational price. Acrobat Pro is also installed on the Sage 4510 desktop computers and on 

the computers in the VCC north lobby with the Sage 4510 image. 

 

Finally, print a copy of your file (as described below) and verify that everything prints as 

expected. 

18. Printing the PDF Files 

To print a PDF file from Acrobat Reader or Acrobat, select File > Print... and select the 

printer. In the print window that appears, there are two important settings to ensure correct 

margins: 

 

1. Make sure that Page Scaling is set to None.  

2. Make sure that Auto-Rotate and Center is not checked.  

19. PDF Tips while preparing your Word document 

Avoid unusual fonts if possible. The safest way to ensure a good-looking PDF document is to 

use Times-Roman (or Times New Roman), Arial (or Helvetica), and Symbol. 

 

If you are going to create the PDF file on a different computer than the one on which you 

prepared the Word file (such as a computer in the Sage 4510 PC lab), you need to ensure that 

the fonts necessary for viewing and printing the resulting PDF file are available during PDF 

creation. Before saving the original document, specify that the fonts should be embedded. In 

Word, select File > Options. In the Word Options window,  click on Save. Select Embed fonts 

in the file. Do no select Embed only the characters used in the document (best for reduc-

ing file size) or Do not embed common system fonts. 

 


