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Overview

Overview

OpenOffice.org has a component (OOo Math) for mathematical equations.  OOo Math
provides mathematical objects which can be embedded in other OOo documents, or saved on
their own.

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the "License"); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is Math Objects: The Equation Editor. The Initial Writer(s) of
the Original Documentation is/are Ian Laurenson © 2004. All Rights Reserved. (Initial Writer
contact(s): hillview@paradise.net.nz. The Initial Writer contact(s) is to report  errors in the
documentation. For questions regarding how to use the software, subscribe to the Users Mail
List and post your question there: http://support.openoffice.org/index.html.)

Contributor(s): Daniel Carrera rewrote the explanatory section of the document.

Portions created by Daniel Carrera are Copyright © 2004. All Rights Reserved. (Contributor
contact(s): dcarrera@openoffice.org.)

All trademarks within this guide belong to legitimate owners.

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Acknowledgments
This chapter is based on two documents written by Fred Saalbach. 

Modifications and updates

Version Date Description of Change

1.0 21 November 2004 First published edition
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Introduction

Introduction

OpenOffice.org (OOo) has a component for mathematical equations.  It is most commonly
used as an equation editor for text documents, but it can also be used with other types of
documents or stand-alone.  When used inside Writer, the equation is treated as an object
inside the text document.

Important note: The equation editor is for writing equations in symbolic form (as in equation 1).
If you want to evaluate a numeric value, this is not the chapter you want.  See the Calc guide.

df x
dx

=ln  xtan−1x2  (1)

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Selection toolbox
appears. You will also see a small box (with a gray border) in your document, where the
formula will be displayed.

Figure 1. Writer document showing Equation Editor , Selection toolbar, and location of resulting equation.
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Introduction

The equation editor uses a markup language to represent formulas.  For example, “%beta”
creates the Greek character beta (  ).  This markup is designed to read similar to English
whenever possible.  For example, “a over b” produces a fraction:

a
b

Entering a Formula
There are three main ways of entering a formula:

• Type markup in the equation editor.

• Right-click on the equation editor and select the symbol from the context menu.

• Select a symbol from the Selection toolbox.

The context menu and the Selection toolbox insert the markup corresponding to a symbol.
Incidentally, this provides a convenient way to learn the OOoMath markup.  When you select
a symbol from the Selection toolbox, it will show up like this in this equation editor:

<?> times <?>

And it will display on screen in Writer like this:

×

When you are editing in the equation editor, you need to remove the <?> and replace it with
the terms of the equation. For example, “5 times 4” produces 5×4 .  Below is a short list of
common equations and their corresponding markup.

Display Command Display Command

a=b a = b  %gamma  %GAMMA

a2 a^2 an a_n

∫ f  x dx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a
b

a over b a
b

stack { a # b }

a sqrt {a} u vec u

x× y x times y x⋅y x cdot y
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Complex Formulas

Complex Formulas

Of course, most people can figure out how to do something simple like a .  The problems
appear when you try to write more complex equations.  This section explores some general
situations and suggests solutions.

Brackets are your friends
You may have heard your professor say this.  It is true for science, and it is true for OOo.
The equation editor knows nothing of order of operation.  To make moderately complex
formulas, you must use brackets. For example:

Display Command

x=−b±b2−4 ac
2 a

x = { -b +- sqrt  { b^2 - 4ac }   } over { 2a }

Tip: Squiggly brackets can be used to collect terms without the bracket appearing in the
equation.

Sums and integration
The “sum” and “int” commands can optionally take in “from” and “to” parameters.  These
are used in a way that is meant to resemble how the equation is read in English.  These
parameters can be used singly or together.  For example:

Display Command

∑
n=1

∞

an
1
n2

sum from { n = 1 } to infinity { a_n + 1 over n^2}

∑
a∈A

a3 sum from { i in A } { a^3 }

∫
a

b

x2 1
x

dx
int from a to b { x^2 + 1 over x dx }

∫


r eid  int from %alpha { r(%theta)e^{i%theta} d %theta }

Tip: Though they look the same, the “sum” command is more flexible than “%SIGMA”.

Tip: Use “infinity” to produce the ∞  symbol.
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Complex Formulas

Matrices
Matrices are done through the matrix command.  The basic syntax is:

Display Command

a b
c d

matrix { a # b ## c # d }

A single “#” symbol is used to separate entries within a given row.  Two “#” symbols are
used to separate different rows.

One of the first problems people have with matrices is working with brackets.  Regular
brackets have a fixed size, which doesn't fit well with matrices (see the table below).
OOoMath provides “scalable brackets”.  These brackets adjust in size (“scale”) to fit the size
of their contents. To obtain scalable brackets, use the left( and right) commands.

Display Command Type

det a b
c d


det   (  matrix { a # b ## c # d }   ) normal

deta b
c d det  left(  matrix { a # b ## c # d }  right) scalable

Tip: Use left[ and right] to obtain square brackets.

Derivatives
To write a derivative, or a partial derivative, use the “over” command.  That is, treat it as if it
were a fraction.  For higher-order derivatives, use the ^ symbol, like an exponent.

Display Command

df t 
dt

=∂ f
∂ x

dx
dt
∂ f
∂ y

dy
dt

{df(t)} over {dt} = {partial f} over {partial x} {dx } over {dt}
                             + {partial f} over {partial y} {dy } over {dt}

Math Objects 4



Complex layout

Complex layout

Often, the problem is not in writing the equation as such, but obtaining the desired layout.
There are some features that can help:

• Adjust alignment with “alignl” (left alignment), “alignr” (right alignment) and
“alignc” (centered).

• Use matrices for columned layout.

• Use white space and several lines to make your equation understandable.

• Use ~ or ‘ to produce white space on the equation.

Tip: You can insert white space and additional lines in the markup without affecting the output
of the equation.

The following example illustrates most of the above.

Display Command

S n = 1rr2⋯rn

rS n = r⋯rnrn1

1−r S n = 1−rn1

S n = 1−rn1

1−r

matrix {
   S_n     #{}={}# alignl  1 + r + r^2 + dotsaxis + r^n ##
  rS_n     #{}={}# alignl  r + dotsaxis + r^n + r^{n+1} ##
(1-r)S_n #{}={}# alignl 1 - r^{n+1} ##
   S_n     #{}={}# alignl {1 - r^{n+1} } over {1-r}
}

In addition to matrices, you can also used the newline command to move to a new line.
Notice (below) that the newline command does not have to be on a line of its own.

Display Command

x y=3
x− y=1

x + y = 3   newline   x – y = 1
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Tips and tricks

Tips and tricks

Customizing the interface
There are a few ways to customize the equation editor's interface to make you more
productive.  Here are some suggestions:

• Show/hide the Selection toolbox with View > Selection.

• Turn off AutoUpdate with View >AutoUpdate display to improve speed.  You can
still update the formula manually by pressing F9 or through View > Update.

• Turn the editor into a floating window:

1) Hover the mouse above the border of the equation editor.

2) Hold down the Control key.

3) Drag the editor away from the main window.

Numbering equations
Equation numbering is possible and simple.  Sadly, this feature is deeply hidden.  To insert a
formula with a number, follow these steps:

1) Start a new line.

2) Type fn and then press F3.

You will see a numbered formula appear:

E=mc2  (2)

Then double-click on the formula to edit it.  For example, here is the Riemann Zeta function:

 z =∑
n=1

∞ 1
nz

 (3)

The number in the equation is stored in the form of a field. To refer to an equation by its
number (for example, “as shown in Equation (2)”):

1) Insert > Cross-reference..

2) Click on the References tab. (See Figure 2.)

3) Under Type, select Text.

4) Under Selection, pick the equation number.

5) Under Format, choose Reference.

6) Click Insert.
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Tips and tricks

Done! If you later add more equations to the paper before the referenced equation, all the
equations will automatically renumber and the cross-references will update.

Figure 2. Inserting a cross-reference to an equation number.

Math Objects 7



Math commands - Reference

Math commands - Reference

Unary / binary operators
Table 1. Commands, unary & binary

Operation Command Display

+sign +1 1
-sign -1 −1
+/- sign +-1 ±1
-/+ sign neg 1 ∓1
Boolean not neg a ¬a
Addition + a + b ab
Multiplication dot a cdot b a⋅b
Multiplication (X) a times b a×b
Multiplication (*) a * b a∗b
Boolean and a and b a∧b
Subtraction (-) a - b a−b
Division (fraction) a over b a

b
Division (operand) a div b a÷b
Division (slash) a / b a /b
Boolean or a or b a∨b
Concatenate a circ b a °b
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Math commands - Reference

Relational operators
Table 2. Commands, relations

Operation Command Display

Is equal a = b a=b
Is not equal a <> b a≠2
Approximately a approx 2 a≈2
Divides a divides b a∣b
Does not divide a ndivides b a∤b
Less than a < 2 a2
Greater than a > 2 a2
Similar to or equal a simeq b a≃b
Parallel a parallel b a∥b
Orthogonal to a ortho b a⊥b
Less than or equal to a leslant b ab
Greater than or equal to  a geslant b ab
Similar to a sim b a~b
Congruent a equiv b a≡b
Less than or equal to a <= b a≤b
Greater than or equal to a >= b a≥b
Proportional a prop b a∝b
Toward a toward b ab
Arrow left a dlarrow b a⇐b
Double arrow left and right a dlrarrow b a⇔b
Arrow right a drarrow b a⇒b
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Math commands - Reference

Set operations 
Table 3. Commands, set operators

Operation Command Display

Is in a in B a∈B
Is not in a notin B a∉B
Owens A owns b A∋b
Empty set emptyset ∅
Intersection A intersection B A∩B
Union A union B A∪B
Difference A setminus B A∖B
Quotient A slash B A/B
Aleph aleph ℵ
Subset A subset B A⊂B
Subset or equal to A subseteq B A⊆B
Superset  A supset B A⊃B
Superset or equal to A supseteq B A⊇B
Not subset A nsubset B A⊄B
Not subset or equal A nsubseteq B A⊈B
Not superset A nsupset B A⊅B
Not Superset or equal A nsupseteq B A⊉B
Natural Numbers Set setN ℕ
Set of Integers setZ ℤ
Set of rational numbers setQ ℚ
Set of real numbers setR ℝ
Set of complex numbers setC ℂ
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Math commands - Reference

Functions
Table 4. Commands, function

Operation Command Display

Exponential func e^{a} ea

Natural logarithm ln(a) ln a 
Exponential function exp(a) exp a 
Logarithm log(a) log a 
Power a^{b} ab

Sine sin(a) sin a 
Cosine cos(a) cos a 
Tangent tan(a) tan a 
Cotangent cot(a) cot a 
Square root sqrt{a} a
Arcsine arcsin(a) arcsin a
Arc cosine arccos(a) arccos a 
Arctangent arctan(a) arctan a
Arc cotangent arccot(a) arccot a 
nth root nroot{a}{b} ab
Hyperbolic sine sinh(a) sinh a 
Hyperbolic cosine cosh(a) cosh a 
Hyperbolic tangent tanh(a) tanh a 
Hyperbolic cotangent coth(a) coth a
Absolute value abs{a} ∣a∣
Arc hyperbolic sine arsinh(a) arsinh a
Arc hyperbolic cosine arccosh(a) arcosh a 
Arc hyperbolic tangent arctanh(a) artanh a
Arc hyperbolic cotangent arccoth(a) arcoth a 
factorial fact(a) a!
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Math commands - Reference

Operators
All operators can be used with the limit functions (“from” and “to”)

Table 5. Commands, operators

Operation Command Display

Limit lim(a) lim a
Sum sum(a) ∑ a
Product prod(a) ∏ a
Coproduct coprod(a) ∐ a
Limits from and to (shown
with intigral)

int from {r_0} to {r_t} a
∫
r0

r t

a

Intigral int{a} ∫a
Double intigral iint{a} ∬a
Tripple Intigral iiint{a} ∭a
Lower limit shown with
summation symbol 

sum from{3}b ∑
3

b

Curved intigeral lint a ∮a
Double curved intigeral llint a ∯a
Tripple curved intigeral lllint a ∰a
Upper limit shown with
product symbol

prod  to{3} r
∏

3

r
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Attributes
Table 6. Attributes

Operation Command Display

Acute accent  acute a a
Grave accent grave a a

Reverse circumflex check a a
Breve breve a a
Circle circle a å
Vector arrow vec a a
Tilde tilde a a
Circumflex hat a a
Line above bar a a
Dot dot a ȧ
Wide vector arrow widevec abc abc
Wide tilde widetilde abc abc
Wide circumflex widehat abc abc
Double dot ddot ä
Line over overline abc abc
Line under underline abc abc
Line through overstrike acb acb
Ripple dot dddot a a
Transparent (useful to get a
placeholder of a given size)

phantom a

Bold font bold a a
Italic font1 ital a a
Resize font size 16 qv qv
Following item in sans serif
font2

font sans qv qv

Following item in serif font font serif qv qv
Following item in fixed font font fixed qv qv

1 Unquoted text that isn't a command is considered to be a variable. Variables are, by default, italicized.

2 There are three custom fonts: sans serif (without kicks), serifs (with kicks), and fixed (non proportional). To
change the actual fonts used for custom fonts and the fonts used for variables (unquoted text), numbers and
functions, use: Format > Fonts.
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Math commands - Reference

Operation Command Display

Make color of following text
cyan

color cyan qv qv

Make color of following text
yellow

color yellow qv qv

Make color of following text
green

color white qv qv

Make color of following text
white

color green qv qv

Make color of following text
blue

color blue qv qv

Make color of following text
red

color red qv qv

Make color green returns to
default color black

color green X qv X qv

Brace items to change color
of more than one item

color green {X qv} X qv
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Others
Table 7. Commands, others

Operation Command Display

Infinity infinity ∞
Partial partial ∂
Nabla nabla ∇
There exists exists ∃
For all forall ∀
H bar hbar ℏa
Lambda bar lambdabar ƛ
Real part re ℜ
Imaginary part im ℑ
Weierstrss p wp ℘
Left arrow leftarrow 
Right arrow rightarrow 
Up arrow uparrow 
Down arrow downarrow 
Dots at bottom dotslow 
Dots at middle dotsaxis ⋯
Dots vertical dotsvert ⋮
Dots diagonal upward dotsup ⋰
Dots diagonal downward dotsdown ⋱
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Brackets
Table 8. Commands, braces

Operation Command Display

Round Brackets (a) a 
Square Brackets [b] [b]
Double Square Brackets ldbracket c rdbracket 〚c〛
Single line lline a rline ∣a∣
Double line ldline a rdline ∥a∥
Braces lbrace w rbrace {w}
Angle Brackets langle d rangle 〈d 〉
Operator Brackets langle a mline b rangle 〈a∣b〉
Group brackets (used for
program control)

{a} a

Scalable round brackets
(add the word “left before a
left bracket and “right”
before a right bracket).

left ( stack{a # b # z} right ) abz
Square brackets scalable
(as above).

left [ stack{ x # y} right ] [ xy]
Double square brackets
scalable

left ldbracket c right rdbracket 〚c〛

Line scalable left lline a right rline ∣a∣
Double line scalable left ldline d right rdline ∥d∥
Brace scalable left lbrace e right rbrace {e }
Angle bracket scalable left langle f right rangle 〈 f 〉
Operator brackets scalable left langle g mline h right

rangle 
〈 g∣h 〉

Over brace scalable {The brace is above} overbrace
a The brace is above

a

Under brace scaleable {the brace is below}underbrace
{f}

the brace is below
f
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Formats
Table 9. Commands, formats

Operation Command Display
Left Superscript a lsup{b} ab

Center Superscript
sum(a)a csup{b} a

b

Right Superscript a^{b} ab

Left subscript a lsub{b} ab

Center subscript a csub{b} a
b

Right subscript a_{b} ab

Align character to left stack { Hello world # alignl
(a) }

Hello world
a

Align character to center stack{Hello world # alignc(a)} Hello world
a 

Align character to right stack { Hello world # alignr(a)} Hello world
a 

Vertical stack of 2 binom{a}{b} a
b

Vertical stack, more than 2 stack{a # b # z} a
b
z

Matrix stack matrix{a # b ## c # d} a b
c d

Common mathematical
arrangement

matrix{a # "="b ## {} # "="c} a = b
= c

New Line asldkfjo newline sadkfj asldkfjo
sadkfj

Small gap (apostrophe) stuff`stuff stuff stuff
Large gap (tilde) stuff~stuff stuff stuff
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Characters – Greek
Table 10. Characters, Greek

%ALPHA A %BETA B %CHI X %DELTA  %EPSILON E
%ETA H %GAMMA  %IOTA I %KAPPA K %LAMBDA 
%MU M %NU N %OMEGA  %OMICRON O %PHI 
%PI  %PSI  %RHO P %SIGMA  %THETA 
%UPSILON  %XI  %ZETA Z
%alpha  %beta  %chi  %delta  %epsilon 
%eta  %gamma  %iota  %kappa  %lambda 

%mu  %nu  %omega  %omicron  %phi 
%pi  %rho  %sigma  %tau  %theta 
%upsilon  %varepsilon  %varphi  %varpi  %varrho ϱ

%varsigma  %vartheta  %xi  %zeta 

Characters - Special
Table 11. Characters, special

%and ∧ %angle ∢ %element ∈ %identical ≡

%infinite ∞ %noelement ∉ %notequal ≠ %or ∨

%perthousand  %strictlygreaterthan ≫ %strictlylessthan ≪ %tendto 
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