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• “What surprises me most about people’s skills 
is how poor their writing and grammar are, 
even for college graduates. If we can’t get the 
basics right, there is a real problem.” 

• Eleonora Sharef  

• www.hireart.com 

http://www.hireart.com/


MS Office and Windows Tips and Tricks 

 



MS Office 

• Versions 

• Editions 



Versions 

• 2003 

• 2007 

• 2010 



2003 

• Completely unpubliczed, MS  introduced Speech 
Recognition into Word 2003.  It was removed from MS 
Office in later versions, but SR was transferred to the OS 
beginning with Vista and is in all versions of Windows 7 
except starter edition.   
 

• Text to speech (TTS) was only available in Excel 2003.  
However there were several macros available through the 
internet which could be installed into Word 2003. 
 

• TTS in 2003 utilitzed the Windows Speech API in Windows 
XP.  A similar API is available in later versions of Windows.  
SAPI 4 and 5 are the latest available. 



2007 

• Introduced new format (DOCS, XLSX, PPTX) 
which earlier versions of Office (2003) can't 
open or edit without adding a download from 
Microsoft.com which allows Office to open 
and edit  



2010 

 



Editions 

• Basic 

• Professional 

• Home Student Edition 



Basic 

• Includes Word, Excel and Outlook. 



Professional 

• Includes Word, Excel, Powerpoint, Access, 
Onenote and Publisher. 

 

• Retails for approximately $499US 

 

• Is available for qualified students at an 
academic price. 



Home Student Edition 

• Includes Word, Excel, Powerpoint and 
Onenote. 

 

• Retails for $149US 



Windows 

• WSR 

• Keyboard Shortcuts 

• Accessibility 



WSR 

• Windows Speech Recognition 

• Voices 



Windows Speech Recognition 

• WSR is only available in Vista and Windows 7.  
There is a dictation component in Word 2003, 
but NOT for Word 2007 or Word 2010. 



Keyboard Shortcuts 

• Keyboard shortcuts for Word 2007, 

http://office.microsoft.com/en-us/word-help/keyboard-shortcuts-for-microsoft-office-word-HP010147626.aspx?pid=CH100965071033


Accessibility 

• System 

• Programs 



System 

• Mouse 

• Sticky Keys 



Programs 

• Narrator 

• Magnifier 



Text To Speech 

Word 2003 

In Excel 2007 

Using the Speak Feature in Office 2010 

•  It also makes it easy to hear text-to-speech playback of the original text 
through the Play and Stop buttons.  

• The Speak feature in Office 2010 enables text-to-speech in OneNote, 
Outlook, PowerPoint, and Word. By default, Speak is not present on the 
Ribbon, so you will need to add it to either the Ribbon or the Quick Access 
Toolbar.   Note, you may want to use text-to-speech playback without 
turning on the Mini Translator or with the keyboard instead of the mouse.  

•  Speak requires a text-to-speech engine matching the language of the text.  
You can see your installed text-to-speech engines in the Control Panel:  

•  Excel also supports text-to-speech playback through Speak Cells in the 
Ribbon or Quick Access Toolbar.  



Text To Speech 

Let’s begin by adding Speak to the Quick Access Toolbar:  

1. Start by launching Word, and open the Backstage View by clicking on the 
File button. 

2. Click Options and navigate to the Quick Access Toolbar tab. 

3. In the Choose commands from: drop-down menu, select Commands Not 
in the Ribbon. 

4. Select Speak from the scroll box and click Add > >. 

5. Click OK, and the Speak icon will now appear in the Quick Access Toolbar. 



Text To Speech 

You can also add Speak to the Ribbon by using the following steps:  

1.  Start by launching Word, and open the Backstage View by clicking on the 
File button. 

2.  Select the Customize Ribbon tab in Options. 

3.  In the Choose commands from: drop-down menu, select Commands Not 
in the Ribbon. 

4.  Create a custom tab or a new group by clicking New Tab or New Group 
(You can rename the Tab or the Group using the Rename… button) 

5.  Select Speak from the scroll box and add it to your custom Tab and Group 
by clicking Add > >. 

6.  Click OK, and the Speak icon will now appear in the Ribbon.  



Text To Speech 

Speak is now ready for text-to-speech playback, when the cursor is within a 
word or you have selected some text!  

1. Click Speak to begin text-to-speech playback. Clicking the button during 
speech will cancel playback.  

2. Word supports custom keyboard shortcuts for commands. This allows you 
to use Speak without adding it to the Ribbon or the Quick Access Toolbar. 
In the Customize Ribbon menu click Customize…, select the All Commands 
category, and bind the SpeakStopSpeaking command to the hotkey of 
your choice. 

3. Speak is disabled until you select text whose language matches one of 
your installed engines. Click Speak to begin text-to-speech playback. 
Clicking the button during speech will cancel playback.   



Text To Speech 

• Voices 

• Word 

• Changing Voices 



Voices 

• Windows XP 

• Windows 7 

• Windows 8 



Windows XP 

• Microsoft Sam 



Windows 7 

• Microsoft Anna 



Windows 8 

• three new client (desktop) voices - Microsoft David 
(US male) and Hazel (UK female) and Zira (US female) 
which sound more natural than Microsoft Anna.  

 

• MS Anna is not installed in Windows 8 



Word 

• Word 2003 

• Word 2007 

• Word 2010 



Changing Voices 

 

http://support.microsoft.com/kb/306902


OneNote 

• Many of us carry a notebook or notepad around to 
take notes for business, school, or personal projects. 
But can you easily find — and decipher — the info you 
need? Is it convenient to share your notes with others? 
Take control with Microsoft Office OneNote 2007, the 
easy-to-use note-taking and information-management 
program where you can capture ideas and information 
in electronic form. Insert files or Web content in full-
color, searchable format or as icons that you can click 
to access. Watch this demo to see how simple it is to 
gather, format, organize, and share information. And 
then say goodbye to your notepad! 

http://office.microsoft.com/en-us/onenote-help/get-started-with-microsoft-office-onenote-2007-HA010032521.aspx?CTT=5&origin=HA010168634


OneNote 

• Office Versions 

• Quick Reference 

http://office.microsoft.com/en-us/onenote-help/get-started-with-microsoft-office-onenote-2007-HA010032521.aspx?CTT=5&origin=HA010168634


Office Versions 

• 2007 Student Home 

• ALL 2010 Editions 



Microsoft 

• A PDF download for OneNote from Microsoft 

http://www.mineralarea.edu/ComputerResources/documents/QuickReferenceCard-GettoKnowOneNote2007-Training-MicrosoftOffic.pdf


Custom Guide Download 

• A PDF File for download form Custom Guide 

http://www.customguide.com/computer-training/quick-references


Formatting 

• Styles 

• Highlighting 

• Fonts 



Styles 

• Styles save time and make your document look good 

• One of the great things about using a word processor is that you can 
create documents that look professionally typeset. 

Headings are in a font that contrasts with body text. 

Paragraphs are separated with just enough white space. 

Elements such as bulleted lists are indented.  
Emphasized text is in a contrasting color. 

• The document may even include special elements such as a table of 
contents.  

http://office.microsoft.com/en-us/word-help/format-your-document-with-styles-RZ010356279.aspx?CTT=1


Styles 
 

 Using direct formatting 

• Word provides several ways for you to achieve each of these effects in 
your document. For example, to format headings, you can select the text, 
apply bold formatting, and then apply a slightly larger font size than the 
size that you use for the body text.  

• Applying formatting in this manner is known as direct formatting. The 
process of applying direct formatting can be tedious. It's easy to make 
mistakes, and you might not get a good looking document. In the example 
in the previous paragraph, you must repeat the direct formatting process 
for each heading, and you must be careful to select the same font size 
every time.  

http://office.microsoft.com/en-us/word-help/format-your-document-with-styles-RZ010356279.aspx?CTT=1


Styles 
 

 Using direct formatting (continued) 
 

• If you want subheadings, you must decide how to differentiate the 
subheadings from the headings (smaller size? italicize?) and repeat the 
direct formatting process for each subheading. If you don't have expertise 
in design or typography, it may take some time before you create a look 
that you like. 

• Furthermore, documents that are formatted by direct formatting are 
difficult to update. If you want to change the look of the document, you 
must select each element and apply the new formatting choices. 

 

http://office.microsoft.com/en-us/word-help/format-your-document-with-styles-RZ010356279.aspx?CTT=1


Styles 
 

Using styles 

• By contrast, when you use styles to format your document, you can 
quickly and easily apply a set of formatting choices consistently 
throughout your document. 

• A style is a set of formatting characteristics, such as font name, size, color, 
paragraph alignment and spacing. Some styles even include borders and 
shading.  

• For example, instead of taking three separate steps to format your 
heading as 16-point, bold, Cambria, you can achieve the same result in 
one step by applying the built-in Heading 1 style. You do not need to 
remember the characteristics of the Heading 1 style. For each heading in 
your document, you just click in the heading (you don't even need to 
select all the text), and then click Heading 1 in the gallery of styles. 

• If you decide that you want subheadings, you can use the built-in Heading 
2 style, which was designed to look good with the Heading 1 style. 

http://office.microsoft.com/en-us/word-help/format-your-document-with-styles-RZ010356279.aspx?CTT=1


Styles 
Using styles (continued) 

• The Quick Styles that you see in the gallery of styles are designed to work together. 
For example, the Heading 2 Quick Style is designed to look subordinate to the 
Heading 1 Quick Style. 

•  The body text of your document is automatically formatted with the Normal Quick 
Style. 

•  Quick Styles can be applied to paragraphs, but you can also apply them to 
individual words and characters. For example, you can emphasize a phrase by 
applying the Emphasis Quick Style. 

•  When you format text as part of a list, each item in the list is automatically 
formatted with the List Paragraph Quick Style. 

• If you later decide that you want headings to have a different look, you can change 
the Heading 1 and Heading 2 styles, and Word automatically updates all instances 
of them in the document. You can also apply a different Quick Style set or a 
different theme to change the look of the headings without making changes to the 
styles. 

 

http://office.microsoft.com/en-us/word-help/format-your-document-with-styles-RZ010356279.aspx?CTT=1


Styles 
 

Built-in styles turn on timesaving features 

 

• The built-in styles (Heading 1, Heading 2, etc.) provide other benefits, too. 
If you use the built-in heading styles, Word can generate a table of 
contents automatically. Word also uses the built-in heading styles to make 
the Document Map, which is a convenient feature for moving through long 
documents. 

 

•  Tip   Try it. If you have a document that uses the built-in heading styles, 
open it, and on the View tab, in the Show/Hide group, select the 
Document Map check box. Click a heading in the document map to jump 
to the corresponding part of the document. 
 

 

http://office.microsoft.com/en-us/word-help/format-your-document-with-styles-RZ010356279.aspx?CTT=1


Highlighting 
When you apply highlighting, it is added as an annotation (annotation: An 
element that you can add to mark up your document, including text, 
highlighting, freeform text or shapes, or a picture.) to your document. 

Apply highlighting 

1. On the Annotations toolbar, click Highlighter . 

2. Drag on the page to highlight the text or graphics you want. 

Note:  To turn off highlighting, click Select on the View toolbar. 

Remove highlighting 

Select the highlighting.  How? 

1. On the Annotations toolbar, click Select Annotations . 

2. Click the highlighting. 

3. Press DELETE. 

 



Highlighting 

• Find 

• Marker 



Find 

• The  way to find highlighted text is to use the Find function. Find is 
particularly handy if there’s a lot of highlighting, and you think you might 
miss some using the zoom function. It’s also handy for finding highlights 
you can’t see, such as those hiding behind empty paragraph marks or 
graphics. Both Word 2003 and 2007 work the same way: 

1. Press Ctrl+F to open the Find and Replace window. 

2. Click More. 

3. Click Format. 

4. Select Highlight. 

5. Highlight should be the only ‘find’ option. Click Find Next to find the 
next highlighted passage. 



Marker 

• To highlight text in color in Microsoft Word 2007, start by selecting the 
portion of text you want to emphasize with a background color. 

• Then, click on the Home tab of the Ribbon: under the Font block of 
commands, there is an icon of a color marker. To highlight the text in 
yellow, the default marker color, simply click on the highlighter button 
itself, and the selected text's background now stands out in yellow. 

•  To highlight text in a color different than yellow, click on the highlighter 
button's dropdown arrow: this will open a menu that displays a palette of 
colors available for text highlighting. Unlike text color, the highlight color 
cannot be customized through the custom color wheel. 

 



Marker 

• Word 2007 includes 15 highlighting colors - as named by Word: yellow, 
bright green, turquoise, pink, blue, red, dark blue, teal, green, violet, dark 
red, dark yellow, gray-50%, gray-25%, black, and "No Color" (a 16th color - 
which removes highlighting from the text selected when you click this 
menu item). 

• Notice that as you move your mouse pointer above each of the highlight 
color while some text is selected in your document, Word 2007 displays a 
real time preview of how the selected text will appear once highlighted 
with the color currently under your cursor. 

• To accept the highlight color, click on the color swatch, and your text now 
appears with the background color you picked from the highlighter 
button's dropdown menu: 

 

 

 



Addins 

• Zotero 

• WordTalk 

 



Zotero 

• Zotero [zoh-TAIR-oh] is a free, easy-to-use tool 
to help you collect, organize, cite, and share 
your research sources. It lives right where you 
do your work—in the web browser itself.  

http://www.zotero.org/


WordTalk 

• WordTalk is a free text-to-speech plugin 
developed for use with all versions of 
Microsoft Word (from Word 97 up to Word 
2010). It will speak the text of the document 
and will highlight it as it goes. It contains a 
talking dictionary to help decide which word 
spelling is most appropriate. 

http://www.wordtalk.org.uk/Home/


NoteTaking 

• OneNote 

• Outline View 



OneNote 

• See OneNote Tab 



Outline View 

• See Outline View Tab 



Paper Writing 

• Outlining 

• Spelling 

• Fields 

• Bibliography 



Outlining 

• Outline View 

• Outline numbered 



Spelling 

• Autocorrect 

• Check While You TYpe 

• Custom Dictionary 



Autocorrect 

• Special Terms 



Check While You TYpe 

 



Custom Dictionary 

Not into the main dictionary, but if the words are in the correct file format, 
you can supply the file as a custom dictionary. 

 

1. The file has to be a straight ASCII file (not a Word .doc or .docx). 

2. The file has to have the extension .dic 

3. Each word has to be on a line by itself. 

4. The words have to be in alphabetical order (I'm not sure what happens if 
they're not. Word MIGHT sort them for you.) Note that upper case letters 
are "lower than" lower case letters. 

5. I think that lower case letters also match words in documents with upper 
case letters, but the reverse may not be true. That is, letters in upper case 
on the dictionary may match only upper case letters in documents. 

6. The file should be added to this directory: 

 



Custom Dictionary 

 
In Windows XP: C:\Documents and Settings\your 
username\Application Data\Microsoft\Proof 
 
In Windows Vista: C:\Users\your username\ 
AppData\Roaming\Microsoft\UProof 
 
(Note: If the directory Appdata doesn’t appear in Windows Explorer, 
enter the full path name in Explorer’s address window.) 
 
The custom dictionary has to be added to the dictionary list this way. 
 
 



Custom Dictionary 

In versions of Word prior to Word 2007: 

1. Click the Tools->Options menu item. 

2. Click the Spelling & Grammar tab. 

3. Click the Custom Dictionaries button. 

4. Click the Add button. 

5. Navigate to the dictionary, select it and click the Open button. The 
dictionary should now be added to the dictionary list box. 

6. To be in use, it has to have a check in its checkbox. 

7. To make the dictionary the default, select it (don't uncheck it) and click the 
Change Default button. 

8. Click OK. 

 

 



Custom Dictionary 

 
In Word 2007: 

1. Click the round Office button in the upper-left corner of the window. 

2. Click the Word Options button. 

3. Click Proofing. 

4. Continue as in Step 3, above. 

 



Fields 

    Click where you want to insert a field. 
•     On the Insert menu, click Field. 
•     In the Categories box, click a category. 
•     In the Field names box, click a field name. 
•     Select the options you want. 

 
 Notes  
    If you want to see the codes for a particular field in the Field dialog 
box, click Field Codes. 
    To nest a field within another field, first insert the outer, or 
"container" field, using the Field dialog box. In your document, place 
the insertion point inside the field code where you want to insert the 
inner field. Then use the Field dialog box to insert the inner field. 
 



Fields 

• Page Counts 

• Word Count 

• Page Numbers 

• Date/Time 

• Other Fields 



Page Counts 

• Insert the number of words in your document 

• Click where you want to add the number of words that are in your 
document. 

• On the Insert tab, in the Text group, click Quick Parts. 

• Click Field. 

• In the Field names list, click NumPages, and then click OK. 



Word Count 

• Insert the number of words in your document 

• Click where you want to add the number of words that are in your 
document. 

• On the Insert tab, in the Text group, click Quick Parts. 

• Click Field. 

• In the Field names list, click NumWords, and then click OK. 



Page Numbers 

• Include Page or Page X of Y with the page number 

• On the Insert tab, in the Header & Footer group, click Page Number. 

• Click Top of Page, Bottom of Page, Page Margins, or Current Position 
depending on where you want page numbers to appear in your document. 

• Do one of the following: 

• To include the word Page with the page number, scroll down in the gallery 
and choose a page number design under the heading Page X. 

• To include the total number of pages with the page number, scroll down in 
the gallery and choose a page number design under the heading Page X of 
Y. 

 



Date/Time 

• When you click Date & Time in the Text group on the Insert tab, 
Microsoft Office Word inserts a DATE field. 
 

• You can also insert a DATE field in the body of a document by doing 
the following: 
 

• On the Insert tab, in the Text group, click Quick Parts, and then click 
Field. 
 

• In the Field dialog box, under Field names, click Date. 
 

Note   The DATE and TIME fields can display a date, a time, or both, 
depending on the format you specify in a date-time picture switch. 

 
 



Other Fields 

 



Bibliography 

 

http://office.microsoft.com/en-us/word-help/create-a-bibliography-HA010067492.aspx?CTT=1


 



Editing 

• Find and Replace 

• Comments 

• Autosummarize 



Find and Replace 

Find text 

• You can quickly search for every occurrence of a specific word or phrase 

• On the Home tab, in the Editing group, click Find. 

• In the Find what box, type the text that you want to search for. 

• Do one of the following: 

• To find each instance of a word or phrase, click Find Next. 

• To find all instances of a specific word or phrase at one time, click Find All, 
and then click Main Document. 

Note   To cancel a search in progress, press ESC. 



Find and Replace 
Find and replace text 
• You can automatically replace a word or phrase with another — for example, you can replace 

Acme with Apex. The replacement text uses the same capitalization as the text that it 
replaces unless you select the Match case check box. For example, if you search for AKA and 
replace it with Also known as, the result is ALSO KNOWN AS. 

• If the Match case check box is selected, Office Word 2007 searches only for words that match 
the case of the word or phrase that you typed in the Find what box. For example, if you 
search for AKA, the result includes AKA but not aka. 

Note   If you don't see the Match case check box on the Replace tab, click More. 

• On the Home tab, in the Editing group, click Replace. 

• Click the Replace tab. 

• In the Find what box, type the text that you want to search for. 

• In the Replace with box, type the replacement text. 

• Do one of the following: 

• To find the next occurrence of the text, click Find Next. 

• To replace an occurrence of the text, click Replace. After you click Replace, Office Word 2007 
moves to the next occurrence of the text. 

• To replace all occurrences of the text, click Replace All. 

Note   To cancel a replacement in progress, press ESC. 



Find and Replace 

Find and highlight text on the screen 

• To help you visually scan a document for every occurrence of a word or 
phrase, you can search for all occurrences and highlight them on the 
screen. Although the text is highlighted on the screen, it isn't highlighted 
when the document is printed. 

• On the Home tab, in the Editing group, click Find. 

• In the Find what box, type the text that you want to search for. 

• Click Reading Highlight, and then click Highlight All. 

•  Note   To turn off highlighting on the screen, click Reading Highlight, and 
then click Clear Highlighting. 

 

 



Find and Replace 

Find and replace specific formatting 

• You can search for and replace or remove character formatting. For 
example, you can search for a specific word or phrase and change the font 
color, or you can search for specific formatting, such as bold, and change 
it. 

• On the Home tab, in the Editing group, click Replace. 

• If you don't see the Format button, click More. 

• To search for text with specific formatting, type the text in the Find what 
box. To find formatting only, leave the box blank. 

• Click Format, and then select the formats that you want to find and 
replace. 

• Click the Replace with box, click Format, and then select the replacement 
formats. 

 



Find and Replace 

Find and replace specific formatting (continued) 

Note   If you also want to replace the text, type the replacement text in the 
Replace with box. 

• To find and replace each instance of the specified formatting, click Find 
Next, and then click Replace. To replace all instances of the specified 
formatting, click Replace All. 



Find and Replace 

Find and replace paragraph breaks, page breaks, and other items 

• You can search for and replace special characters and document elements such as 
tabs and manual page breaks. For example, you can find all double paragraph 
breaks and replace them with single paragraph breaks. 

• On the Home tab, in the Editing group, click Find. 

• If you don't see the Special button, click More. 

• Click Special, and then click the item that you want. 

• If you want to replace the item, click the Replace tab, and then type what you 
want to use as a replacement in the Replace with box. 

• Click Find Next, Find All, Replace, or Replace All. 

• To cancel a search in progress, press ESC. 

Tip   To quickly find items such as graphics or comments, click Select Browse Object 
Button image on the vertical scroll bar, and then click the item that you want. You can 
click Next Button image or Previous Button image to find the next or previous item of 
the same type. 

 

 



Comments 

Insert a comment 

• You can type a comment. On a Tablet PC, you can insert a voice comment 
or a handwritten comment 

• Type a comment 

• Select the text or item that you want to comment on, or click at the end of 
the text. 

• On the Review tab, in the Comments group, click New Comment. 

• Type the comment text in the comment balloon or in the Reviewing Pane. 

Note   To respond to a comment, click its balloon, and then click New 
Comment in the Comments group. Type your response in the new comment 
balloon. 



Comments 

Delete a comment 

• To quickly delete a single comment, right-click the comment, and then 
click Delete Comment. 

• To quickly delete all comments in a document, click a comment in the 
document. On the Review tab, in the Comments group, click the arrow 
below Delete, and then click Delete All Comments in Document. 



Comments 

Delete comments from a specific reviewer 

• On the Review tab, in the Tracking group, click the arrow next to Show 
Markup. 

• To clear the check boxes for all reviewers, point to Reviewers, and then click All 
Reviewers. 

• Click the arrow next to Show Markup again, point to Reviewers, and then click 
the name of the reviewer whose comments you want to delete. 

• In the Comments group, click the arrow below Delete Button image, and then 
click Delete All Comments Shown. 

Note   This procedure deletes all comments from the reviewer that you selected, 
including comments throughout the document. 

Tip   You can also review and delete comments by using the Reviewing Pane. To 
show or hide the Reviewing Pane, click Reviewing Pane in the Tracking group. To 
move the Reviewing Pane to the bottom of your screen, click the arrow next to 
Reviewing Pane, and then click Reviewing Pane Horizontal. 



Comments 
Change a comment 

• If comments aren't visible on the screen, click Show Markup in the 
Tracking group on the Review tab. 

• Click inside the balloon for the comment that you want to edit. 

• Make the changes that you want. 

Notes  

• If the balloons are hidden or if only part of the comment is displayed, you 
can change the comment in the Reviewing Pane. To show the Reviewing 
Pane, in the Tracking group, click Reviewing Pane. To make the reviewing 
pane run across the bottom of your screen rather than down the side of 
your screen, click the arrow next to Reviewing Pane, and then click 
Reviewing Pane Horizontal. 

• To respond to a comment, click its balloon, and then click New Comment 
in the Comments group. Type your response in the new comment balloon. 

 

 



Autosummarize 

Add AutoSummary Tools to the Quick Access Toolbar 

• Click the Microsoft Office Button Button image, and then click Word 
Options. 

• Click Customize. 

• In the list under Choose commands from, click All Commands. 

• Scroll through the list of commands until you see AutoSummary Tools. 

• Click AutoSummary Tools, and then click Add. 

• The AutoSummary Tools button now appears in the Quick Access Toolbar. 

 

 



Autosummarize 

Automatically summarize a document 

• On the Quick Access Toolbar, click AutoSummary Tools, and then click 
AutoSummarize. 

• Select the type of summary that you want. 

• In the Percent of original box, type or select the level of detail to include in the 
summary. Select a higher percentage of the original document to include more 
detail. 

• If you don't want AutoSummarize to replace your existing keywords and comments 
in the document properties, clear the Update document statistics check box. 

 Notes  

• To cancel a summary in progress, press ESC. 

• After you create your summary, review it to make sure it covers your document's 
key points. Keep in mind that the summary text is a rough draft, and you will 
probably need to fine-tune it. 

 



VBA 

• Visual Basic for Applications (VBA) is an implementation of Microsoft's 
programming language Visual Basic 6 and its associated integrated 
development environment (IDE), which are built into most Microsoft 
Office applications. VBA enables developers to build user defined 
functions, automate processes and access Win32 and other low-level 
functionality through DLLs. It was also built into Office applications apart 
from version 2008 for Apple's Mac OS X, other Microsoft applications such 
as Microsoft MapPoint and Microsoft Visio; as well as being at least 
partially implemented in some other applications such as AutoCAD, 
WordPerfect and ArcGIS. It supersedes and expands on the capabilities of 
earlier application-specific macro programming languages such as Word's 
WordBasic. It can be used to control many aspects of the host application, 
including manipulating user interface features, such as menus and 
toolbars, and working with custom user forms or dialog boxes. VBA can 
also be used to create import and export filters for various file formats, 
such as ODF. 
 



Speech Recognition 

• Windows Speech Recognition 

• Tools 

• Dragon 

• Demo 



Windows Speech Recognition 

• WSR is only available in Vista and Windows 7.  
There is a dictation component in Word 2003, 
but NOT for Word 2007 or Word 2010. 



Windows Speech Recognition 

• Office 2003 

• Windows 7 



Tools 

• Speech Profile Tool 

• Macros 

• MSDN Archive 



Macros 

• Speech Macros 

• Macrobuilder 

http://www.microsoft.com/en-us/download/details.aspx?id=13045


MSDN Archive 

 

http://archive.msdn.microsoft.com/wsrmacros/Thread/List.aspx


Demo 

• Microphone 

• Test 

• Tutorial 

• Basic Commands 



Basic Commands 
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