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Chapter 1. Release notes - IBM i2 Analyst's Notebook
9.2.3

Analyst's Notebook 9.2.3 is available.

Contents
• “Description” on page 1
• “Release highlights” on page 1
• “Virtualization support” on page 2
• “Known problems” on page 2
• “More information” on page 6

Description
i2 Analyst's Notebook is a stand-alone desktop product that is designed to provide users with a powerful,
multidimensional visual analysis tool. It enables government agencies and private sector businesses to
maximize the value of the mass of information that they collect.

With an intuitive and contextual design, i2 Analyst's Notebook allows users to quickly collate, analyze, and
visualize data from disparate sources. Hidden connections and patterns in complex data are quickly
discovered, delivering timely, actionable intelligence to help identify, predict, prevent, and disrupt
criminal, cyber, and fraudulent activities.

Note: The following announcements affect IBM i2 Analyst's Notebook compatibility.

• Analyst's Notebook Version 9.0 and later are not compatible with i2 software that is older than version
8.9.

• This is the last release of Analyst's Notebook to support i2 QRadar Offense Investigator.

Analyst's Notebook only supports the operating systems and supported software listed in the detailed
system requirements. Ensure that existing installs are upgraded to currently supported versions of all the
software required. For more information about the software supported for the current release, see System
Requirements.

Release highlights
The following new and updated features are available:

IBM i2 Analyst's Notebook

The following APARs are fixed in this release of Analyst's Notebook.

• Using shift and right mouse button on the chart background no longer displays a reduced context
menu. [APAR PO08862]

• Charts that contain custom icons created in Analyst's Notebook version 8.9.5 can be opened in later
versions without causing Analyst's Notebook to crash. [APAR PO08863]

• Changes made to the icon frame's default color are saved in the template and do not revert to the
default frame color. [APAR PO08874]

• When a value is left blank in the Conditional Formatting lookup table, it is preserved as blank and
not populated with characters that can interfere with match results. [APAR PO08927]

• Analyst's Notebook no longer initializes a CEF browser instance when it is not required. [APAR
PO08929]
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• Third party plug-ins that call the API method "RefreshIconImages" results in changes to icons being
available in the user interface without the need to restart Analyst's Notebook. [APAR PO08958]

• Using New Zealand specific content supplied from ArcGIS Online in i2 Esri Maps no longer causes
Analyst's Notebook to crash. [APAR PO08973]

• Using shift and numbers 0-9 is a keyboard shortcut for adding members of a selection set to the
current selection. [APAR PO09060]

Virtualization support
Analyst's Notebook is supported on hardware virtualization environments that run any of the operating
systems that are listed in the detailed system requirements. When you run in a virtual environment, any
issues that can be replicated by IBM in a supported operating system are addressed by using the standard
IBM support policy.

Note: Trial editions of IBM i2 Analyst's Notebook cannot be run in virtualized environments.

Known problems
The most up-to-date source for known problems in Analyst's Notebook is the HTML version of these
release notes.

At the time of publication, the following problems were known:

Analyst's Notebook

Table 1. Analyst's Notebook

Problem Description

Unable to use Google Earth to map chart
items

One of the following error messages might be
displayed when you try to map chart items to Google
Earth:

• Unhandled exception has occurred in a
component in your application. If you
click Continue, the application will
ignore this error and attempt to
continue.

• Google Earth failed to initialize.
Please check that Google Earth
version 4.2 or higher is installed,
it is configured correctly and that
your connection to the Google Earth
server is working.

These errors can result if the Google Earth
installation has been corrupted, Google Earth is not
registered correctly, or the version of Google Earth is
not compatible with Analyst's Notebook. Refer to
the following technote for details of how to repair
the installation, register the executable file, or install
a different version.

IBM i2 Analyst's Notebook crashes when trying to
map chart items to Google Earth

Embedded help files cannot render italic text
in Arabic

When you view the embedded help in Arabic on
systems that use Windows 10, any text that set to
italics does not render correctly.
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Table 1. Analyst's Notebook (continued)

Problem Description

Imported entities not merged on the chart if
names have spaces at the end

Imported entities whose names contain spaces at
the end are not merged with entities on the chart.
Remove any trailing spaces in the incoming data
before running the import.

Opening embedded help files causes
Analyst's Notebook to stop responding

If you have i2 Esri Maps installed, and you attempt
to search the embedded help for a connected
product such as IBM i2 iBase, Analyst's Notebook
can stop responding. If this problem occurs, close
Analyst's Notebook and restart it.

In environments that connect to multiple data
sources, Infotips can stop displaying

When Analyst's Notebook is connected to two or
more data sources and i2 Esri Maps is installed and
enabled, Infotips can stop displaying. If this
problem occurs, close one of the connections.

Import specifications that use Hierarchy
layout are not always compatible

If you create an import specification that uses the
Hierarchy layout in Analyst's Notebook version 9.0.1
or earlier, or version 9.0.5 or later, an error occurs if
you try to edit that import specification by using
Analyst's Notebook versions 9.0.2, 9.0.3, or 9.0.4.

An entity type's icon is not shown after you
delete a picture from an event frame

Deleting a picture from an event frame does not
revert to showing the entity type's icon. To show the
entity type's icon, right-click Display > Type Icon, or
select Type Icon on the Display page of the Edit
Event Frame window.

Displaying OLE objects Analyst's Notebook can display .bmp, .jpeg, and .gif
OLE objects without the requirement for a third-
party OLE server. However, the following limitations
apply:

• When you drag files from a browser, an
Unexpected file format error message might
be displayed.

• When you drag an unrecognized file type onto the
chart the error message Unexpected file
format is displayed, and subsequent drag
operations to the chart from Windows Explorer
might fail.

To avoid these problems, select the Home tab, and
then, in the Insert Entities group, insert the image by
selecting OLE Object > Picture. Use the Edit Item
Properties window to add a picture to an entity
representation.
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Table 1. Analyst's Notebook (continued)

Problem Description

Performance problems when you disconnect
from the network

When you disconnect from the network, but a
network printer remains set as the default printer,
switching between tabs in Analyst's Notebook can
take several seconds. When you disconnect from a
network, change the default printer to a local printer.
Then, in Analyst's Notebook select a local printer.

Note: The following registry key value causes
Analyst's Notebook to ignore the user selected
printer, and can be deleted: HKEY_CURRENT_USER
\Software\i2\Default\Printer.

Potentially unable to save entire charts when
you Save as Picture

If your computer has insufficient memory, you might
be unable to save large charts when you select File
> Save as > Save Entire Chart as Picture. To avoid
this problem, save the chart in sections by selecting
File > Save As > Save Current View as Picture, or
save the chart in PDF format by selecting File >
Print > Print to PDF.

Memory issues when charts have a large
number of entities with picture
representations

If you attempt to save a chart with greater than
5500 entities that have picture representations, an
Unexpected file format error message is
displayed. You might be unable to save your chart or
Analyst's Notebook might terminate during the save
process.

Untranslated system attribute names are
displayed when you search for attribute
classes

In a non-English version of Analyst's Notebook,
when you search for attribute classes in the Insert
from Palette task pane, the names of system
attributes are not displayed in their translated form.

Unable to expand items after their data
records are purged

If you purge data records from items that are added
to the chart from data sources, any attempt to
expand these items results in an error.

Colors window is not translated The Colors window always contains US English text,
regardless of the user's settings.

In Arabic and Hebrew, black and white
application windows might appear when you
use the Copy to New Association Chart
feature

When you run in Arabic or Hebrew, selecting the
Copy to New Association Chart feature might result
in a black and then white application window, when
the layouts are applied. A "Windows not responding"
message might also appear. However, Analyst's
Notebook then recovers and continues normally.

i2 Esri Maps not loading If the i2 Esri plug-in does not load correctly, ensure
that the Microsoft Visual C++ 2015 runtime is
installed.
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Table 1. Analyst's Notebook (continued)

Problem Description

Display issues with drawings that cross the
International Date Line

The following problems might occur when a drawing
on an i2 Esri Map crosses the International Date
Line:

• Duplicate labels might appear for the drawing.
• When you edit the drawing, the edit box might be

positioned away from the drawing.
• A line might appear drawn through the shape.
• When you try to export the drawing through the

API, it is exported as two shapes.

Labels not refreshing on the map In i2 Esri Maps, if you replace a textual label on a
drawing with a blank label, parts of the original label
might remain on the map.

Large circles do not render correctly In i2 Esri Maps, drawing a large circle or ellipse that
overlaps itself causes the shape to be drawn
incorrectly.

Problems drawing polygons or polylines on
some maps

In i2 Esri Maps, you might encounter instability
when you are drawing a polygon or polyline on some
map types, for example British National Grid.
Problems can occur when you select and move the
grab handles that lie between the vertices of the
polygon or polyline.

Using i2 Esri Maps in a virtual environment
takes longer to render the graphics layer

Using i2 Esri Maps in a virtual environment requires
access to a physical graphics card that supports
DirectX 11. Many virtualization solutions enable
access to physical graphics cards on a server and
support client access through RDP or their
proprietary container. However, if a remote desktop
is used to access a virtual machine, i2 Esri Maps
uses only WARP (software rendering). When i2 Esri
Maps uses WARP, it can take longer to render the
graphics layer.

In some configurations, reverting to WARP is
unsupported. For example, if you are using Windows
7 in a virtual environment. In these situations, the
map window displays an
ArcGISRuntimeException error and you are
unable to use i2 Esri Maps.

Analyst's Notebook trial version

Table 2. Analyst's Notebook trial version

Problem Description

Installing a purchased version of Analyst's
Notebook after using the trial version requires
an uninstall

You must uninstall Analyst's Notebook trial version
before you install a purchased version. If you
directly upgrade from Analyst's Notebook trial
version to a purchased version, you might encounter
trial license expiry issues.
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Table 2. Analyst's Notebook trial version (continued)

Problem Description

Analyst's Notebook trial version uses a
network license

If you use Analyst's Notebook trial version on a
network where Product Access Management
licensing is used, the trial version might attempt to
use one of the network licenses.

More information
For more information, see the following resources:

• IBM i2 Enterprise Insight Analysis documentation
• IBM Security Learning Academy

IBM i2 Analyst's Notebook

• Product Support
• Release Notes
• Release Notes (pdf)
• System Requirements
• Supported Languages
• Download Document
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries.
Consult your local IBM representative for information on the products and services currently available in
your area. Any reference to an IBM product, program, or service is not intended to state or imply that only
that IBM product, program, or service may be used. Any functionally equivalent product, program, or
service that does not infringe any IBM intellectual property right may be used instead. However, it is the
user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this
document. The furnishing of this document does not grant you any license to these patents. You can send
license inquiries, in writing, to:

IBM Director of Licensing IBM Corporation North Castle Drive Armonk, NY 10504-1785 U.S.A.

The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION
PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT,
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of
express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication.
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of
the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without
incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the
exchange of information between independently created programs and other programs (including this
one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM United Kingdom Limited Hursley House Hursley Park Winchester, Hants, SO21 2JN UK

Such information may be available, subject to appropriate terms and conditions, including in some cases,
payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by
IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any
equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the
results obtained in other operating environments may vary significantly. Some measurements may have
been made on development-level systems and there is no guarantee that these measurements will be the
same on generally available systems. Furthermore, some measurements may have been estimated
through extrapolation. Actual results may vary. Users of this document should verify the applicable data
for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their
published announcements or other publicly available sources. IBM has not tested those products and
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of
those products.
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All statements regarding IBM's future direction or intent are subject to change or withdrawal without
notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate
them as completely as possible, the examples include the names of individuals, companies, brands, and
products. All of these names are fictitious and any similarity to the names and addresses used by an
actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming
techniques on various operating platforms. You may copy, modify, and distribute these sample programs
in any form without payment to IBM, for the purposes of developing, using, marketing or distributing
application programs conforming to the application programming interface for the operating platform for
which the sample programs are written. These examples have not been thoroughly tested under all
conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these
programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business
Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be
trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at
"Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered trademarks or
trademarks of Adobe Systems Incorporated in the United States, and/or other countries.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the
United States, other countries, or both.

Java™ and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or
its affiliates.

ArcGIS, EDN, StreetMap, @esri.com, and www.esri.com are trademarks, registered trademarks, or service
marks of Esri in the United States, the European Community, or certain other jurisdictions.

Other names may be trademarks of their respective owners. Other company, product, and service names
may be trademarks or service marks of others.
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